Deprecated: Function set_magic_quotes_runtime() is deprecated in /home4/mfoster/public_html/cb/forums/include/common.php on line 62

Warning: Cannot modify header information - headers already sent by (output started at /home4/mfoster/public_html/cb/forums/include/common.php:62) in /home4/mfoster/public_html/cb/forums/header.php on line 31

Warning: Cannot modify header information - headers already sent by (output started at /home4/mfoster/public_html/cb/forums/include/common.php:62) in /home4/mfoster/public_html/cb/forums/header.php on line 32

Warning: Cannot modify header information - headers already sent by (output started at /home4/mfoster/public_html/cb/forums/include/common.php:62) in /home4/mfoster/public_html/cb/forums/header.php on line 33

Warning: Cannot modify header information - headers already sent by (output started at /home4/mfoster/public_html/cb/forums/include/common.php:62) in /home4/mfoster/public_html/cb/forums/header.php on line 34
Cross-Browser.com / [xTableHeaderFixed] anchor tags

Cross-Browser.com

X Library Forums

You are not logged in.

Announcement

New user registration is currently disabled.

#1 October 29, 2010 12:53:10 pm

theseeker
Member
Registered: December 11, 2009
Posts: 24

[xTableHeaderFixed] anchor tags

Ok, this will be my last post bugging you about this great library for a while smile

I've verified that anchor tags are problematic with xTableHeaderFixed. If you add anchor tags to any of your demos (especially Table 3, the one with the colspan'd THs in the THEAD) and then add a link to the anchor anywhere else on the page, you'll see that clicking the link actually takes you under the table, and you'll be a few rows off of where you want to be. If you have 3 rows in the THEAD, it will be 3 rows off. It you have 2 rows in THEAD, it will be 2 rows off, etc. I've worked around this by linking x rows higher than the number of rows in the THEAD in my anchor tag, and then the correct row is displayed at the top of the fixed table. The link actually goes to the row - x, which is incorrect, but it looks correct to the user. This might be an issue for users with screen readers, I'm not sure.

It looks like this same issue was reported by Charles Belov on January 27th in this thread: http://cross-browser.com/forums/viewtopic.php?id=791.

The workaround is hacky, but it is better than nothing smile

Thanks again, Mike.

Offline

 

#2 October 31, 2010 5:33:30 pm

MikeFoster
Administrator
From: Alabama, USA
Registered: April 27, 2007
Posts: 874
Website

Re: [xTableHeaderFixed] anchor tags

Hi theseeker, thanks very much for your posts and code. I'll be diving in to this soon.

Offline

 

Board footer

Powered by PunBB 1.2.15
Copyright © 2002–2005 Rickard Andersson

Expand Restore Select Format Eval Load