Deprecated: Function set_magic_quotes_runtime() is deprecated in /home4/mfoster/public_html/cb/forums/include/common.php on line 62

Warning: Cannot modify header information - headers already sent by (output started at /home4/mfoster/public_html/cb/forums/include/common.php:62) in /home4/mfoster/public_html/cb/forums/header.php on line 31

Warning: Cannot modify header information - headers already sent by (output started at /home4/mfoster/public_html/cb/forums/include/common.php:62) in /home4/mfoster/public_html/cb/forums/header.php on line 32

Warning: Cannot modify header information - headers already sent by (output started at /home4/mfoster/public_html/cb/forums/include/common.php:62) in /home4/mfoster/public_html/cb/forums/header.php on line 33

Warning: Cannot modify header information - headers already sent by (output started at /home4/mfoster/public_html/cb/forums/include/common.php:62) in /home4/mfoster/public_html/cb/forums/header.php on line 34
Cross-Browser.com / cant compile tools

Cross-Browser.com

X Library Forums

You are not logged in.

Announcement

New user registration is currently disabled.

#1 January 25, 2010 9:01:17 am

krumpet
Member
Registered: January 24, 2010
Posts: 19
Website

cant compile tools

Hi,

I am trying to use codeblocks to compile the x tools on an ubuntu 9.10.

I get this error

/usr/bin/ld: cannot find -lkernel32

Any idea how I should go about solving this problem? Someone suggested I need to install wine! I do hope he's wrong.

Offline

 

#2 January 25, 2010 5:12:11 pm

MikeFoster
Administrator
From: Alabama, USA
Registered: April 27, 2007
Posts: 874
Website

Re: cant compile tools

Hi krumpet, Welcome to the forums!

I'll give that a try tonight after work.

Thanks!

Offline

 

#3 January 26, 2010 12:54:09 am

MikeFoster
Administrator
From: Alabama, USA
Registered: April 27, 2007
Posts: 874
Website

Re: cant compile tools

I had recently reinstalled Ubuntu 9.10 on another machine. The only thing I've done to it is to accept all the initial software updates. So I ran the following to get the dev tools: sudo apt-get install build-essential, and then installed Codeblocks. I then unzipped the X distribution file, and loaded xc.workspace into Codeblocks. xag and xpp compiled with no problems.

To test xag, I created this file:
cross-browser.com/x/xthf1.xag

options -app +dep
libpath lib/
output examples/xthf1.js
appfiles
examples/xthf1.html



and (from the "x" directory) I ran xc/xag xthf1 - this creates examples/xthf1.js

In examples/xthf1.php I made the following changes to use the new js file:

<!-- <script type='text/javascript' src='../x.js'></script>
<script type='text/javascript' src='../lib/xtableheaderfixed.js'></script> -->
<script type='text/javascript' src='xthf1.js'></script>



and it worked fine.

... Ahhh... I see now. Don't try to build the xc project - that's giving that error. I need to remove the xc project from that zip file. I'll update the X distribution file soon.

Offline

 

#4 January 26, 2010 12:22:05 pm

krumpet
Member
Registered: January 24, 2010
Posts: 19
Website

Re: cant compile tools

Thank you.

I was using build workspace, which trys  to build everything including xc.  When I build the other two individually everything is fine.

Offline

 

Board footer

Powered by PunBB 1.2.15
Copyright © 2002–2005 Rickard Andersson

Expand Restore Select Format Eval Load